From 7b6f9ba0aa18f264c3f231d55c575ff742679fab Mon Sep 17 00:00:00 2001
From: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Date: Sun, 3 Oct 2021 12:03:52 +0900
Subject: [PATCH] Import cluster api and ipc library recipe from EG repo

The cluster api and ipc library was contributed by Nippon Seiki at SPEC-3952.
Original recipe of these was created by Tetsuro Komatsu from Panasonic.

https://github.com/agl-ic-eg/meta-agl/commit/476497689794ec37d5cbfd1f1797dfa060b0bd9b

This patch import these recipe from experimental repository.

Bug-AGL: SPEC-4092

Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Change-Id: I25cb9773753e18621d2ee0e44f54ab9e9f1b4aaf
---
 .../libclusterapi/libclusterapi_git.bb        | 20 +++++++++++++++++++
 .../libclusteripc/libclusteripc_git.bb        | 18 +++++++++++++++++
 2 files changed, 38 insertions(+)
 create mode 100644 meta-agl-lxc/recipes-core/libclusterapi/libclusterapi_git.bb
 create mode 100644 meta-agl-lxc/recipes-core/libclusteripc/libclusteripc_git.bb

diff --git a/meta-agl-lxc/recipes-core/libclusterapi/libclusterapi_git.bb b/meta-agl-lxc/recipes-core/libclusterapi/libclusterapi_git.bb
new file mode 100644
index 00000000..5d9550dd
--- /dev/null
+++ b/meta-agl-lxc/recipes-core/libclusterapi/libclusterapi_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "AGL Instrument Cluster API library"
+DESCRIPTION = "AGL Instrument Cluster API is defined common function API for Instrument Cluster.\
+               This library was contributed by four EG member company."
+HOMEPAGE = "https://confluence.automotivelinux.org/display/IC"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "libclusteripc"
+
+SRC_URI = "git://git.automotivelinux.org/src/libcluster-api;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "fa8ad7927ede4f2a825021d13a8024742b8cb225"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE:append = " \
+        -DCMAKE_SYSROOT=${RECIPE_SYSROOT} \
+"
diff --git a/meta-agl-lxc/recipes-core/libclusteripc/libclusteripc_git.bb b/meta-agl-lxc/recipes-core/libclusteripc/libclusteripc_git.bb
new file mode 100644
index 00000000..00961219
--- /dev/null
+++ b/meta-agl-lxc/recipes-core/libclusteripc/libclusteripc_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL Instrument Cluster IPC library"
+DESCRIPTION = "AGL Instrument Cluster IPC is IPC framework for the AGL Instrument Cluster API.\
+               This library was contributed by four EG member company."
+HOMEPAGE = "https://confluence.automotivelinux.org/display/IC"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://git.automotivelinux.org/src/libcluster-ipc;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "b27fb69aa966866920e86b10f7d10326a0042e33"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE:append = " \
+     -DCMAKE_SYSROOT=${RECIPE_SYSROOT} \
+"
-- 
GitLab